Network Degredation

Incident Report for VMhosts Service

Resolved

This incident has been resolved.
Posted May 26, 2026 - 07:58 UTC

Update

All services are back up and running. If you have any questions, please reach out to us.
Posted May 26, 2026 - 07:57 UTC

Update

During investigation, we believe the issue would have been limited to DRaaS and VCC services. We will update this when we have more infromation.
Posted May 25, 2026 - 19:33 UTC

Update

We are continuing to investigate a possible issue at our DR site.
Posted May 25, 2026 - 17:06 UTC

Investigating

We are investigating reports of possible network degradation. Some users may experience slow performance or intermittent connectivity. We will update this page once we have more information.
Posted May 25, 2026 - 15:44 UTC
This incident affected: Infrastructure as a Service (DC1, DC2, DC3) and Disaster Recovery as a Service - Zerto, Backup as a Service - Veeam Cloud Connect.